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PSoC® Creator™ 4.2 Production Release Notes

Overview

The primary purpose of the PSoC Creator 4.2 release is to provide production support for the PSoC 6
MCU. This release includes a new Peripheral Driver Library (PDL) 3.0.1, new and updated Components,
as well as new and updated Code Examples. This release also provides production-level support for the
PSoC 4100S Plus device and all other previously supported devices.

This release does not replace existing production versions of PSoC Creator (e.g., 4.0 or 4.1); it installs
alongside them. We guarantee that your existing designs can be opened in the new software, but please
upgrade your components to the latest version. To ensure that you can always return to your previous
setup, a backup of your project is automatically created when opening a project in a new version of the
tool. It is stored in a folder named "backup” in the project’s folder.

If you have technical questions, visit www.cypress.com/go/support or call 1-800-541-4736 and select 3.
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PSoC Creator 4.2 Features

PSoC 6 Support

With this release, PSoC Creator provides production support for the PSoC 6 MCU. The PSoC 6 family is
available as a single-core 150-MHz Arm Cortex-M4 device or a dual-core version with a 100-MHz Arm
Cortex-MO+ core.

Source code for each core is located in separate folders in the Workspace Explorer. You can easily
identify the core on which that application source code will execute. Also, both cores have access to all
peripherals and memory. You can move functionality around by simply dragging the files to the
appropriate core folder.

Workspace Explorer (1 project) @]
& 15
& Workspace 'MyP6Workspace' (1 Projects)
=72 Project 'Design0l1’ [CY8C6347BZI-BLD53]
|2 TopDesign.cysch
B Design Wide Resources (Design0l.cydwr)
b Pins
=N\ Analog

anInos

= CMOp (Core 0)
i3 Header Files
=H Source Files

€] main_cm0p.c
=] (M4 (Core 1)
+-IC3 Header Files
EHE Source Files

L] main_cméd.c
=+ Shared Files

snsay | Logeuswniog | siusuodwoy

L

Building projects is fully automated, so you do not need to maintain makefile dependencies and re-build
for each core. The result of a build is always the complete application in a single file that you just program
and go.
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The debugger allows you to connect to either core in seconds; just pick the core you need and start the
debugger normally.

Select Debug Target @I&J

=3 KitProg2/0B1D0C5303147400 PSoC 63 CY8C6347BZI-BLD53

4 PSoC 63 CY8C6347BZ1-BLD53 (CMOp) gﬁg;’ﬁ%ﬁﬂ;ﬁggﬁ“@““

* PSoC 63 CYSC6347BZI-BLDS3 (CW4)... EelE1 vl ayyaliy
Revision: PRODUCTION

Target acquired

Show all targets -

Peripheral Driver Library (PDL)

The Peripheral Driver Library (PDL) provides firmware to manage all the digital and analog peripherals

included with this release, such as CapSense, USB, Bluetooth Low Energy (BLE), USB, and more. PDL is
a suite of highly-efficient, MISRA-compliant drivers for PSoC peripherals with a comprehensive,
searchable documentation package that is HTML-based for easy viewing in any browser.

PSoC Creator 4.2 automatically pulls the drivers you need into your project as you add various
Components. Plus, it adds the required code to include paths maintained for you.

PSoC 4100S Plus

This release of PSoC Creator provides production-level support for the new PSoC 4100S Plus series,
with up to 24 pins that support Cypress’ Smart I/O™ functionality. The Plus-series also extends the PSoC
4100S with a variety of valuable features and resources.
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Components/Code Examples

This release includes the following new and updated Components, as well as code examples for them.
Refer to the Component datasheets and code example documents for more details.

New and Updated Components

The following Components have been added or updated since the previous release to support the
PSoC 6 MCU or PSoC 4100S Plus series.

Component Name Version Component Name Version
ADC_DelSig 3.30 cy_net_join 1.50
ADC_SAR_SEQ_P4 2.50 cy_net_tie 1.50
ADC_UAB 1.0 cy_pins 2.20
AMux 1.80 cy_srff 1.0
AMuxSeq 1.80 cy_stay_awake 1.50
and 1.0 cy_sync 1.0
BLE 3.50 cy_terminal_reserve 1.50
BLE_PDL 2.0 cy_tff 1.0
CAN 3.0 cy_UDB_clockenable 1.0
CapSense 2.0 cy_vref 1.70
CapSense_CSD_P4 2.60 CyControlReg 1.80
CapSense_P4 5.0 cydff 1.30
Comp_PDL 1.0 CyStatusReg 1.90
Count7 1.0 demux 1.10
CRC 2.50 DieTemp_P4 1.0
CSD_Comp_P4 1.0 DMA_Channel_P4 1.0
cy_analog_constraint 1.50 DMA_PDL 2.0
cy_analog_reserve 1.50 Em_EEPROM 2.0
cy_boot 5.70 EMIF 1.30
cy_bufoe 1.10 GPIO_PDL 1.0
cy_constant 1.0 12S_PDL 2.0
cy_dffe 1.0 IDAC_P4 1.10
cy_dmac 1.10 IDAC7_P4 1.10
cy_gsref 2.10 IDAC7_P6 1.0
cy_isr 1.70 LIN 4.0
Cy_mux_constraint 1.50 LPComp_PDL 1.10
Cy_net_constraint 1.50 MCWDT_PDL 1.10
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Component Name Version Component Name Version
mux 1.10 SmartlO_PDL 1.0
nand 1.0 SMIF_PDL 1.10
nor 1.0 SPI_Master 2.50
not 1.0 SPI_Slave 2.70
OneTerminal N/A SysClk_PDL 1.0
OpAmp_PDL 1.0 Sysint_PDL 1.0
or 1.0 TCPWM_Counter_PDL 1.0
PDM_PCM_PDL 2.0 TCPWM_PWM_PDL 1.0
PowerMonitor_P4 2.10 TCPWM_QuadDec_PDL 1.0
RTC_PDL 2.0 TIA 2.0
RTC_PDL 1.0 UAB_VDAC 1.10
Scan_ADC 2.10 UART 2.50
SCB_P4 4.0 VDAC12_PDL 1.0
SCB_EZI2C_PDL 2.0 xnor 1.0
SCB_I12C_PDL 2.0 xor 1.0
SCB_SPI_PDL 2.0 ZeroTerminal N/A
SCB_UART_PDL 2.0

Design Impact

SEGGER J-Link Software Version

When using the SEGGER J-Link Debugger probe with a third-party IDE (e.g., Eclipse) and PSoC 6, make
sure to use V6.30 or later. There may be issues with any earlier version.

PSoC Analog Coprocessor Support Suspended in PSoC Creator 4.2

Support for the PSoC Analog Coprocessor has been temporarily suspended in PSoC Creator 4.2. You
should continue to use PSoC Creator 4.1 instead. If you try to open a PSoC Analog Coprocessor project
in PSoC Creator 4.2, an error will display indicating that the device is not supported.

Support for the PSoC Analog Coprocessor will be added in the near future from the Web-Based Content
Delivery (WCD) system. Please monitor the PSoC Creator 4.2 Start Page and the PSoC Analog
Coprocessor home page (http://www.cypress.com/products/psoc-analog-coprocessor) for an update
announcement. Use the Tools > Find New Devices dialog to install the new devices.
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PDL Software Package Imports not Automatically Updated

Some PDL software package imports, such as bootloader_sdk, have been updated to new minor versions
(i.e., 2.0.0 to 2.10.0). If you have a design from a Beta version PSoC Creator 4.2 using these packages,
the design will not be automatically updated to use the new versions. Open Build Settings > Peripheral
Driver Library and re-select the desired packages under the “Software package imports” section.

Build Settings (B
Configurstior: [ Debug (éetive] -]
Toolchain: [#RM GCC 5.4-2016 g2 ypdale -
F-Design0l ®) Default [Took > Options] C\Pragrann Files [486)\CypressyPOLY 01
Code Generation
Debug “ Custom

Custornizer
[ Peripheral Driver Library
~-TargetIDEs T Expand iz Collapse I Check A1l T Uncheck &1
- CMI+ ARM GO 5.4-2016-62-upda

Software package imports:

2.8 M GCC 52115 mprts Package Variant Yersion Description
=PDL
=[] erypto Base library | = |2.0.0 CRC, DES, SH&, PRNG, TRNG
= bootloader
= bootloader_sdk
Care 2.10.0 |Bootloader SDI core files
App type Bootloader 2100 |Files specific to a bootloader a)
Communication UART b 2100 |UART cammmunication files
Caramunication BLE & 2.10.0 |BLE communication files
{7 Communication I2C 2100 |I2C caramunication files
{7 Communication SPI 2.10.0 |SPI communication files
=-RTOS
[=FFreeRTOS 9.0.0  |FreeRTOS Real Tirne Operating
7] Memory Management | heap_1 ~|9.0.0  |The simplest. Does not suppar
= utilities
=[] Retarget /O 1100 |Redirects IfQ functions of the

oK l l Aaply ] l Cancel

VDAC12 Component Renamed to VDAC12_ PDL

The prototype VDAC12 Component has been renamed to VDAC12_PDL to reflect that it is a PDL
Component to be used with PSoC 6 MCUs and the PDL. The impact of this change is if you open a
design created with PSoC Creator 4.2 Beta, the Component will display an error in the schematic, as
follows:

VDAC_1
Cannot find component VDAC12

This design uses a component that could not be
found. Please check your dependencies via the
Project > Dependencies menu. If this design is a
Cypress Application Note or Kit, please read the
documentation (PDF file) to make sure it is
supported by this version of PSoC Creator.

Delete the old Component, and drag the updated VDAC12_PDL Component from the Component
Catalog onto the schematic in the location of the old Component. You will likely have to re-adjust any
parameters that you configured previously.

System Reserved Resources

The PDL reserves certain system resources for internal use. These resources include IPC resources, like
the first 16 IPC semaphores and interrupt lines to the Cortex MO+ CPU. Using any of these resources in
your design will lead to unexpected behavior. Please refer to the PDL APl Reference Guide for details.
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Updated Range for Interrupt Vectors

Cypress has changed the valid range for interrupt vectors assigned to the PSoC 6 Cortex-MO0+. In
previous releases, the valid vector range in the PSoC Creator Design-Wide Resources Interrupt Editor for
Cortex-MO+-serviced interrupts was 0-27. In this production release, the valid range is now 3-29.

This change was made to move the Cypress interrupts for SysCall, IPC Pipe endpoint 0, and Crypto to
Deep-Sleep capable interrupts. It is expected that most users will benefit from this setup, since these
capabilities are often necessary in the Deep-Sleep state. If you previously assigned interrupts to the
Cortex-MO+ vectors 0, 1, or 2, you will now receive an error in PSoC Creator and need to change your
vector assignments to valid vectors. If you wish to override these defaults, you can do so in firmware by
editing your cy_ipc_config.h header file. For more information, refer to the PDL Documentation accessible
from the Workspace Explorer, under the Documentation tab for a PSoC 6- based design.

IMO Enable/Disable Removed from Design-Wide Resources Clock Editor

In previous releases of PSoC Creator, the Clock Editor contained a check box to disable the PSoC 6
IMO. This check box has been removed and the IMO can no longer be disabled. The associated PDL
APIs have also been removed. If your project used this setting, PSoC Creator will overwrite your choice
and you will have to remove any usage of the PDL APIs for disabling/enabling the IMO.

PSoC Creator 4.2 will not Find Some Older Component Versions

As mentioned in the previous PSoC Creator 4.1 Release Notes, only the latest versions of Components
now ship with the product. Older Component versions are available from the WCD system. If you are
working on a project and update your software to PSoC Creator 4.2, you will see the following symbol in
the schematic file for impacted Components.

CapSense_1
Cannot find v 3.10 of component
CapSense_P4
This design uses an older version of a component
than is available in your dependencies. Please
update the component via the Project > Update
Components menu.

To resolve this issue, you have the choice between the following:
m  Download the original versions using WCD tools.
m  Update to the latest versions, which are always included in the distribution.

For more information about WCD tools, refer to the PSoC Creator Help.
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Supported Devices

The design flow and tools available in this release of PSoC Creator support the following:

Family/Series/Product Line Part Numbers

PSoC 6000, PSoC 6100, PSoC 6200, PSoC 6300 CY8C6*

PSoC 5LP CY8C52*LP CY8C54*LP CY8C56*LP CY8C58*LP
PRoC BLE CYBL1*

EZ-BLE modules CYBLE*

PSoC 4200, PSoC 4200L, PSoC 4200M, PSoC 4200 CY8C42* CY8C42*L CY8C42*M CY8C42*BL
BLE, PSoC 4200DS CY8C42*DS

PSoC 4100, PSoC 4100M, PSoC 4100S, PSoC 4100S CY8C41* CY8C41*M CY8C41*S CY8C41*BL
Plus, PSoC 4100 BLE

PSoC 4000, PSoC 4000S, PSoC 4000DS CY8C40* CY8C40*S CY8C40*DS

PSoC 3 CY8C32* CY8C34* CY8C36* CY8C38*
FMO+ S6E1A* S6E1C1* S6E1C3*

System Hardware Manager (SHM) CYSHM*

Supported Tool Chains

Toolchains for PSoC 4, PSoC 5LP, and PSoC 6 (ARM)

m  ARM GCC - The GCC ARM Embedded toolchain GCC 5.4-2016-g2-update is installed with
PSoC Creator. This toolchain has no use restrictions and does not require license activation (it is
distributed under the terms of the GNU Public License).

m  ARM GCC Generic — This option can be used to select a separately-installed version of the ARM
GCC toolchain.

m  ARM MDK Generic — This option can be used to select a separately-installed version of the ARM
Microcontroller Development Kit. The officially supported version is 4.72a.

Toolchains for PSoC 3 (8051)

DP8051 Keil™ 9.51

The Keil PK51 Professional Developers Kit for PSoC is installed with PSoC Creator. It supports
optimization levels 0 through 5. If you would like to use the compiler optimization levels above level 5, you
should purchase the standard PK51 product by contacting Keil.

m In North, Central, or South America... sales.us@keil.com
m In Europe, Asia, Africa, or Australia... sales.intl@keil.com

The free Keil toolchain comes with a 30-day evaluation license. You can extend the license, without cost,
by registering the product from within PSoC Creator (Help > Register > Keil...). Note that the extended
license is for one year and that you will need to re-register it each year.
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DP8051 Keil Generic

This option can be used to select a separately-installed version of the Keil toolchain. While any version
can be selected, the only officially supported versions are 8.16, 9.03, 9.51.

Installation

Minimum and Recommended System Requirements

The following are system requirements to install and use PSoC Creator. Each requirement specifies a
minimum that your system must meet or exceed.

PSoC Creator will execute correctly in highly resource-constrained systems. However, performance
(startup time, project creation and opening, build times, and so on) may be impacted when resources are
scarce. The most directly impacted performance metric is build time. The following sections provide
examples of the resource scarcity impact.

Note During initial startup, PSoC Creator builds and caches component DLL files used to display the
component parameter editors. As a result, the tool will launch less quickly the first time after a new
installation or a Windows® reboot.

Summary

Hardware/Operation System Requirements Minimum

=  Processor 1.3 GHz or faster 32-bit (x86) or Intel 64/
AMDG64 64-bit

= RAM 1.5GB
=  Free Hard Drive Space 5GB
= Screen Resolution 1024x768
= USB 2.0

Software Prerequisites * Minimum Version

=  Microsoft Internet Explorer (not IE8 beta) 7

= NET Framework 4.0

=  Adobe Reader (for viewing PDF Documentation) 9.2 **
=  Windows Installer 3.1

3.27 (included with PSoC Creator)
8.16 (9.51 provided)
3.0.1 for PSoC 6, 2.1.0 for FMO+

=  PSoC Programmer
=  Keil Compiler (For PSoC 3 Only)
= PDL

* To install and run PSoC Creator, you may also need to install additional software. The Cypress Installer
will guide you through the process if the additional programs are not already installed.

** For Windows 7, the minimum required version of Adobe Reader is version 9.2. You can download the
latest version here: http://get.adobe.com/reader/. You can also use a hon-Adobe PDF reader if you
prefer; however, Cypress has no recommendations for any particular non-Adobe reader or version.
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Processor
1.3 GHz or faster 32-hit (x86) or Intel 64/AMD64 64-bit processor is required.

PSoC Creator exhibits a predictable relationship between CPU speed and build time above 1 GHz.
Doubling the CPU speed, e.g., from 1 GHz to 2 GHz or 1.5 GHz to 3 GHz, almost halves the build time.

On a fast (3 GHz) PC, simple designs can build in about one minute. At low speeds even designs that fill
the device and generate complex routing solutions will build in under 5 minutes.

Operating System

One of the following Windows platforms is required:
m  Windows 7 and Windows 7 SP1 (32- and 64-bit supported)
m  Windows 8 and Windows 8.1 (32- and 64-bit supported)
m  Windows 10 (32- and 64-bit supported)

Memory

A minimum of 1.5 GB of RAM is required.

Free Disk Space

PSoC Creator requires 5 GB of free disk space. PSoC Creator will install and run with just 1 GB of free
disk space. However, in order to allow Windows to do memory paging, we recommend a minimum free
disk space requirement of 5 GB.

If your disk is highly fragmented it will severely impact memory paging time and can result in very long
build times. Disks that are nearly full are particularly prone to fragmentation. We recommend de-
fragmenting your disk if you experience excessively long build times (10 minutes or more).

USB

PSoC Creator requires a USB 2.0-compliant or newer host to program and debug.

Screen
A resolution of 1024x768 pixels or higher is required.

Note The build time examples given above were obtained with new product installations on minimally
fragmented disks with no other applications running. If your build times exceed these expectations we
recommend closing unnecessary applications, adding RAM to the system (to reduce paging) and
ensuring that there is sufficient free and unfragmented disk space.

Software Update Instructions

As part of the installation process, the Cypress Update Manager utility will also be installed and located
on the Start menu. You can use this utility to update all Cypress programs you have installed when
updates for them become available.
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Open Source

Portions of this software package are licensed under free and/or open source licenses such as the GNU
General Public License. Such free and/or open source software is subject to the applicable license
agreement and not the Cypress license agreement covering this software package. The applicable
license terms will accompany each source code package. You may obtain the source code of such free
and/or open source software at no charge from the following web site: www.cypress.com/go/opensource.

Installation Notes

The installation process is a set of wizards that walk you through installing various components. You can
install PSoC Creator and various prerequisites from the web. The installation provides all the necessary
prerequisites, and the wizards to guide you through installing the appropriate software.

Note Do NOT plug in your Miniprog3 until all software installation is complete AND the PSoC Creator
application has been opened.

Web Installation

After downloading the software from the web (www.cypress.com/creator), run the PSoC Creator single
package executable.

1. Double-click the PSoC Creator executable file to launch the installer.

2. Follow the prompts to install PSoC Creator. The Cylnstaller for PSoC Creator opens and displays
a series of steps to install PSoC Creator, and it will perform pre-requisite checks and install the
prerequisites.

3. When complete, close the installer.

Further Reading

The primary documentation for PSoC Creator is provided in the Help, which you can open from the Help
menu or by pressing [F1]. Other documents included with this release are also available from the Help
menu, under Documentation. These documents include (but are not limited to):

m  Quick Start Guide
m  System Reference Guide
m  Component Author Guide

Cypress provides a web page specifically for PSoC Creator at www.cypress.com/creator.

Other documentation includes (but is not limited to):
m  Device Datasheets
Device Architecture Technical Reference Manual (TRM)
Device Registers TRM
Application Notes
Training

Contact your Cypress representative, as needed.
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